Ad Radar
  • Subscribe to a Magazine
Item Posts    Sort Order

wont idle when cold and runs rough

 
306fordstang
New User
Posts: 11
Joined: 12/03
Posted: 12/18/03 11:10 AM









535.1 
i have a 1986 ford mustang with a 302 efi. My problem is when it s cold and i try to start it up it idles rough and dies the high idle/ choke doesnt turn on. recently when driving i would shut off engine and go to restart and would not start has spark/ fuel at rails but just doesnt fire. then i go and try to start vehicle up like a hour later and i have to hold it to the floor and then it fires. i'm thinking of maybe a t.p.s. or i heard about a idle air circuit. please reply.
 

Post Reply
CopCoupe
Enthusiast
Posts: 318
Joined: 10/03
Posted: 12/18/03 12:35 PM

Sounds like your computer is receiving the wrong signal as to the temperature of the engine, so the computer doesn't richen the mixture as well as step up the idle speed.  

Post Reply
306fordstang
New User
Posts: 11
Joined: 12/03
Posted: 12/18/03 02:42 PM

i just recently changed the coolant temp censor for the ecu not the gauge and it didnt do anything. it still didnt want to idle up and was running very rough and rich.  

Post Reply
djfab1
New User
Posts: 11
Joined: 12/03
Posted: 12/19/03 05:49 PM

Frist thing you need to do is check the fuel pressure. The pressure regulator maybe bad. If that is ok then I might would try a known good MAP sensor. They are good about going bad and not setting a code or anything. Plus make sure that the vacumn line that goes to the MAP sensor is good. Also check for vacumn leaks.  

Post Reply
306fordstang
New User
Posts: 11
Joined: 12/03
Posted: 12/19/03 07:05 PM

i forgot what map sensor stands for and where its located but yeah i will check the fuel pressure and try to scan for codes.  

Post Reply
1988mustang
New User
Posts: 2
Joined: 12/03
Posted: 12/20/03 12:10 PM

I have a 88 GT I just put a new 302 with a trickflow cam, windsor jr heads and my car does the same thing. I was told to clean the IAC valve i believe that is what it is called. Use carb cleaner. It is on the side of the throttle body facing the front of the engine. It's right behind where you put oil in.  It has 2 bolts and 1 wire plugged into it. I cleaned that and it helped but I still have the same problem.  Try that and see if it works. By the way I'm selling my car for $5,000 if you know anybody. I could send pictures if needed, Thanks Scott  

Post Reply
CopCoupe
Enthusiast
Posts: 318
Joined: 10/03
Posted: 12/23/03 01:40 PM

map = manifold absolute pressure


maf = mass air flow


iac = idle air control


tps = throttle position sensor


egr = emissions gas recirculation


pcv = positive crankcase ventilation


etc = to continue on in a manor that is unnecessary


All of these abbreviations mean exactly what they imply.  Sorry, got away from myself.

 

Post Reply
Dreaco
New User
Posts: 3
Joined: 01/04
Posted: 01/31/04 02:59 AM

I have an 89 gt with the same problem as yours, hard as hell to start when its cold, I repaced the iac and the coolant temp sensor, no luck.  Whats worse is mine sometimes idles as high as 3,000 rpm  ive had to turn the idle screw all the way out just to keep it normal.  In addition my check engine light stays on, but when i go to read the codes it the scaners wont read any.  If any one has answers please email me.


reaco3@aol.com">Dreaco3@aol.com


 


Thanks

 

Post Reply