• Subscribe to a Magazine
123 Last
Item Posts    Sort Order

Speedometer erratic. 2005 Mustang, V6.

 
pbarkeresq
New User
Posts: 1
Joined: 01/10
Posted: 01/27/10 03:02 PM

I have a 2005 v6 with same problem.  My mrchanic couldn't figure it out.  Sai sensors ok etc.  I wonder if this is problem endemic to 2005 v6?  Could it be electical sys related or cruise control related?  

Post Reply
mlannon
New User
Posts: 1
Joined: 02/10
Posted: 02/05/10 08:10 AM

I am having this same problem. I live in San Diego and have a 2005, V6 with a little over 80K on it, lovingly maintained and I was driving home last night at my usual 75-80 mph, looked down and my needle was maxed out at over 120. I pulled over to the side of the road and at a dead stop it only went down to 45. I shut the car off, restarted and this is where it stayed at a dead stop, and is where it continues to stay shut off as well. I am nowhere near having $600 to fix this problem so I am going to have to try and find some other solution...  

Post Reply
patmagrawen
New User
Posts: 2
Joined: 12/09
Posted: 02/07/10 11:21 AM

Denice Halicki has killed the Eleanor Mustang.  Denice Halickiclaimed a copy of a Shelbys design from Chip Foose and then sued Shelby and claimed it as her own and now she is actually signing Eleanor Mustang cars.
Denice hides behind God to sue innocent people and claim she is a victim.  SCAM SCAM SCAM.  She is one of the biggest cons and crooks in the market today.  A signed Eleanor from her is worthless today and the laughing stock of the Mustang industry.
Thanks a lot! Denice, for taking something so precious away from true Mustang lovers.  You single handedly killed the Eleanor.  Denice Halicki,  you are an embarrassment for women who truly want to start a honest business  

Post Reply
septemberman
New User
Posts: 1
Joined: 03/10
Posted: 03/25/10 08:17 AM

Same problem. North Miami beach, fl.  I also have a 2005 ford mustang.  date: 3/25/2010  any word of a recall? a phone number to call? anything? did anyone go ahaead and get their car fixed? and what was the culprit?  

Post Reply
dwilsonjr74
New User
Posts: 5
Joined: 03/10
Posted: 03/25/10 03:19 PM

thanks for the info...  

Post Reply
Kunalk
New User
Posts: 1
Joined: 05/10
Posted: 05/23/10 06:59 PM

I've a 2005 Ford Mustang V6 and am facing similar issue with my speedometer. Looking at this thread, looks like lot of people have faced similar issues - What is the best option? Did any one contact Ford and get any resolution?

How much did it cost to get it fixed with any registered auto mechanics (Firestone/Pepboys etc.)?  

Post Reply
mcella
New User
Posts: 1
Joined: 08/10
Posted: 08/22/10 04:37 PM

My speedometer started acting up when i turned car off the needle would stay stuck on the last speed i was going then when i started car it would continue to go up till it stuck on 120.Dealership said to replace instrument cluster at 650.00 WOW.I replaced the sensor on the transmission that didn't help.So I put it off due to finances then started to have transmission problems.I replaced the instrument cluster and its running good again.The speedometer sends a message to your transmission so it knows when to shift so dont wait too long to fix this problem.  

Post Reply
dquick1csr
New User
Posts: 1
Joined: 08/10
Posted: 08/28/10 06:11 PM

I am posting here to become, hopefully, part of the solution.  In an attemtpt to investigate online any information I can glean regarding the fact that almost every guage on my 2005 V6 Mustang has ceased to function - with the exception of my fuel guage, which HAS spent one day off so far - I have found that this is most definitely NOT an uncommon problem.  It certainly should be a recall.  Everyone who has mentioned an estimate to repair has quoted $500-$650.  This is just unacceptable for something that is an obvious inherent problem.  My Ford dealership told me that they would charge me $100 just to LOOK at the problem.  I appreciate all those of who took the time to post the phone numbers and Ford websites to contact.  I'm on my way there now.  Good luck.  

Post Reply
jboisestate
New User
Posts: 3
Joined: 08/10
Posted: 08/29/10 05:10 PM

I'm here in Idaho with a 2005 Ford Mustang V6 & bought it bran new only have 45,000 miles on it & have treated it tenderly. I recall a hand full of times when the gas gauge would say it was empty after I just put gas in it & then it would go back to working if I shut the car off & restarted & it has been fine working now knock on wood but now my speedometer is not working at all says I'm going 40 mph when I'm stopped & 70 miles an hour when I'm driving. I filled out the contact Ford form & hopefully can get some help here as this evidently is a problem as it has happened to several of us as I can see here.  

Post Reply
19mustanggirl88
New User
Posts: 1
Joined: 09/10
Posted: 09/03/10 10:36 AM

Mad My 2005 mustang definitely has a problem with the speedometer! With reading all of these posts.... there should be a RECALL!!!! Shocked  We shouldn't have to pay $500 to fix a glitch in the making of this year. It's the first year for this style mustang and obviously they were slacking when production was underway. We should contact the Ford Company and tell them we need this taken care of for free!!  

Post Reply
frustratedstanggal
New User
Posts: 2
Joined: 09/10
Posted: 09/05/10 06:08 PM

I finally have found others having the same problem I have been having. Shortly after purchasing my 2005 5 speed V6 mustang the speedometer started acting up. Yes, sometimes it reset and now for the most part it sits on the peg past 120. My fuel gauge has read epmty after filling it up too. It the car sits in the sun (it is black) it sometimes doesn't read right too. The other morning when I started it up the speedometer was reading 80. It has not moved from that peg for months. I went to ask about my problem when it first happened at the service center as I had to leave emergency on a road trip. I was never acknowledged once. I finally cornered a mechanic that did not want to give me the time of day and was rude. I refuse to go back to a dealership and pay $95 to have it looked at after the way I was treated. I have noticed my car is starting to act up. I have gone to other mechanics that have yet to figure this problem out. I want to SCREAM!!!! I am going to call the number I saw in another post on this thread and complain too!  

Post Reply
frustratedstanggal
New User
Posts: 2
Joined: 09/10
Posted: 09/06/10 09:18 AM

I bought my 2005 last December with 65,000 miles. The speedometer went out within two weeks of owning it  

Post Reply
jboisestate
New User
Posts: 3
Joined: 08/10
Posted: 09/12/10 06:11 PM

OK after I posted this I called the Ford dealership who acted like they have never heard of this issue. They said they do not look at internet forums like this or blogs & the best thing is for ALL of you that are having speedometer issues is to call them as the more that report this directly the better chance of us having a recall.

Luckily I did have the landcar warranty which was set to expire in 2 months thank goodness I still had time. I took it to a Ford dealership who put in a new instrument cluster & it is working fine. Total cost $555 but luckily I had a $100 deductible & it was covered under the warranty.

Vehicle is working fine now. I'm still not happy about paying the $100 & will save my receipt should this finally get the recall it should & hopefully get reimbursed.

Everyone on hear please call Ford directly & report.

Thank You.  

Post Reply
jboisestate
New User
Posts: 3
Joined: 08/10
Posted: 09/12/10 06:12 PM

It is the instrument cluster I guarantee you. Cost $555! Hopefully you have warranty as it is covered under that. Call Ford to report directly as the more of us that do hopefully will get a recall that it should.  

Post Reply
bearster40
New User
Posts: 1
Joined: 09/10
Posted: 09/25/10 09:38 PM

Im glad to see we are not the only ones having issues with the gauges.  Gas gauge reads empty when I know I just filled up and have not traveled very far.  Put gas in and shuts have after 3 - 4 gals.  Dealer saids it could have been the pumps, but this had happened more than once and have tried several stations.  Speedometer stuck on 120 when I'm going slower than the speed of traffic or Parked in Driveway going 40MPH.  Water temp is always reading cold.  I shut the car on and off several times, as a mechanic told me to, so it would reset the gauges.  Sometimes it works, but here lately not at all.  Have complained to Ford.  Will not spend the money to fix it.  And like most warrenties, the problem started after the warranty expired.  

Post Reply
123 Last