Ad Radar
  • Subscribe to a Magazine
12 Last
Item Posts    Sort Order

Dash Gauges

 
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/06/13 01:21 AM

Having trouble with my gauges on my 67 need help  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/06/13 01:25 AM

The Resistor on the back of the dash has constant power on both sides and the gauges r taking off all the way up except for the gas it does not do anytthing any more  

Post Reply
waynep712222
User
Posts: 223
Joined: 04/13
Posted: 11/06/13 08:44 AM

on the instrument cluster voltage regulator...


one wire gets switched power..

one wire is to the gauges..

and the mounting tab is GROUNDED to the cluster housing..

but the HUGE question... is  WHERE is the cluster GROUNDED to the body...

and WHERE is the body hooked to the negative battery..???


lets look at this slightly earlier  mustang image..

66 Mustang Cluster Ground Location


if you notice... there is a what is best described as a side forked terminal under the mounting screw for the ICVR...  that is the GROUND wire for the dashboard...

it goes over to the firewall reinforcement...

hopefully there will be a ground strap from the back of the engine to the firewall..


and perhaps.. in addition to that..  a tab part way down the negative battery cable that connects to the body... so it has a negative battery to the body connection on the inner fender...

does your car run???

please spend a minute and run the voltage drop test with your digital volt meter to prove the grounds..

engine running.. headlights on..   digital meter set to 20 volts DC..

1.  Negative to positive battery posts.. 14.1 to 14.8 volts is expected..

2.  Negative post to the engine block.. 0.04 volts DC max.

3.  Negative post to the body.. 0.02 volts DC max..

4.  Engine block to the body.. 0.02 volts DC max..

if you get more than the 4/100 or 2/100 volts across the ground side.. you have a ground issue..

you can run the same test between either the end of a pair of jumper cables laid on the floor and only the negative hooked to the battery... and your volt meter jumping from the end on the floor to the cluster housing..   because there is not a lot of current being used.. i am expecting less than 1/100 volt.. 0.01.. you might need to switch to the 2 volt DC scale .. or run a jumper wire from the end of the negative jumper cable under the car to the cluster housing... see if the ICVR starts working again..  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/06/13 09:24 PM

There are no grounds from motor to the body i wll deal with that and let ya know thanks and yes my car runs  

Post Reply
waynep712222
User
Posts: 223
Joined: 04/13
Posted: 11/07/13 02:14 AM

65 66 Mustang Ground Cables


Ground Strap 15 Inch Zpsbc9293c1

paint is not a good conductor ..

star washers also...

Fordfirewallground Zps4692e042  

Post Reply
waynep712222
User
Posts: 223
Joined: 04/13
Posted: 11/07/13 02:22 AM

this image is PRINTABLE .. its a JPG..  print and paste it to a wall in your shop..


VOLTAGE Drop Testing Zpsb5de8fcf  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/07/13 11:07 AM

Wow no wonder eveyone knows you thanks i will do this tonight  

Post Reply
waynep712222
User
Posts: 223
Joined: 04/13
Posted: 11/08/13 01:26 AM

Icon Quote1970TexasAuto:
Wow no wonder eveyone knows you thanks i will do this tonight

wait.... somebody knows me..  Blush

does this mean that they are talking about some of my posts somewhere other than here??/  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/12/13 08:10 AM

No they are not talking about you I just see your post all over this site and I think you have great answers.I installed he grounds last night all the gauges just went all the way up ,can I ground to the bolt holding on the trans to the block the casing is aluminum.Is it possible that the voltage regulater is bad.I will do the voltage drop test tonight and see what I find  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/12/13 11:00 PM

0.0 neg to engine going to move my ground to the block  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/12/13 11:03 PM

0.00 engine to negative going to move my ground  

Post Reply
waynep712222
User
Posts: 223
Joined: 04/13
Posted: 11/12/13 11:07 PM

run the voltage drop test..

post results by number..


1.____

2._______

3._______

4._______

lets start there...

you can run another voltage drop test.. if the above number on 2.,3 and 4 are at or below 0.04 and 0.02 volts ..

find a good ground location under the dash.. and then probe from that body connection to the dash cluster housing.. see if you get 0.00 or 0.02 volts..  you may have to change to the 2 volts SETTING.. and look for a tiny amount of voltage.


remember... we are looking for the voltage drop in a properly connected circuit. as being the 0.04 and 0.02 volts.. this is the resistance of the Copper wire..

if you get more than the 0.04 or 0.02 volts.. you have resistance in the ground circuit that you are measuring..  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/14/13 09:14 PM

1.13.7
2.0.00
3.0.03
4.0.03  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/14/13 09:17 PM

Replaced ICVR and now it works  

Post Reply
1970TexasAuto
New User
Posts: 16
Joined: 11/13
Posted: 11/14/13 09:50 PM

but not the gauges  

Post Reply
12 Last